Club Delphi  
    FTP   CCD     Enlaces   Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Varios
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Desplegado
  #1  
Antiguo 11-11-2010
expertix expertix is offline
Registrado
 
Registrado: feb 2008
Ubicación: Nayarit, Mexico
Posts: 7
expertix Va por buen camino
Question problema con aplicacion en delphi 2007 y windows 7

Hola buen dia a todos!

este es mi primer tema o hilo que hago ya hace tiempo que soy miembro de clup delphi pero no era muy activo ya que deje un tiempo de programar, pero he retomado el camino jeje, bueno les cuento mi problema esperando que alguien pueda ayudarme pues no encuentro la solucion, tengo una aplicacion de punto de venta desarrollada en delphi 2007, pues resulta que esta aplicacion funciona perfecto en sistema operativo XP y Vista, el problema es que cuando instalo la aplicacion en windows 7 parece funcionar bien abre los catalogos muestra informacion pero por ejemplo cuando estoy guardando una factura me marca lo siguiente: "Objeto Parameter mal definido. se proporciono informacion incompleta o incoherente" y ya no puedo guardar la factura.

y lo malo es que no logro ubicar en que parte del proceso marca ese error ya que aveces sale en algun lado y otras en otro y lo peor es que no siempre sale, aveces si puedo guardar la factura sin ningun problema.

en windows XP y Vista no tengo esos problemas solo en windows 7.

si tienen alguna idea de que estara pasando con mi aplicacion se los agradecere infinitamente.

de antemano gracias!
Responder Con Cita
  #2  
Antiguo 11-11-2010
Avatar de Neftali
Neftali Neftali is online now
Aporreador de teclados
 
Registrado: jul 2004
Ubicación: Barcelona - España
Posts: 13.613
Neftali Va camino a la fama
Hombre, sin saber qué parte del programa está fallando es difícil poder ayudarte.
Intenta añadir algun sistema de Debug (o de log) que te de información de qué operaciones se realizan cuando falla.
estaría bien, que dieras más información de la aplicación.
¿Con qué Base de Datos trabaja? ¿Cómo accedes a ella?
...
__________________
Neftalí -web - MyDropBox-
Guía de estilo, Guía alternativa, TAG's.
*Añade tu foto al Club*

(UPDATE) TrackInfo v.1.7b

Contactar con el Clubdelphi


P.D: Más tiempo dedicado a la pregunta=Mejores respuestas.
Responder Con Cita
  #3  
Antiguo 12-11-2010
Avatar de ContraVeneno
ContraVeneno ContraVeneno is offline
You will suffer me.
 
Registrado: may 2005
Ubicación: Torreón, México
Posts: 4.713
ContraVeneno Va por buen camino
Pues seguramente estas utilizando consultas con parámetros y uno de esos parámetros no está tomando el valor que crees debería estar tomando.

Por eso cuando quiere ejecutar la consulta y le falta el valor del parámetro, te marca ese error.
__________________

Responder Con Cita
  #4  
Antiguo 12-11-2010
agustin173 agustin173 is offline
Miembro
 
Registrado: jun 2010
Posts: 158
agustin173 Va por buen camino
los muchachos tienen mucha razon sin saber la parte es dificil determinar algo, y lo que contraveneno dice lo apoyo 100%.

para mi los formatos de fecha chequealo porque tuve muchos problema con windows 7 en los parametros de la fecha eso dependera si es en español o ingles.

si es la fecha cambiala al formato yyyy/mm/dd a ver que pasa si no son las fechas entonces deberas decir cual es el error y la linea.

para poderte ayudar
Responder Con Cita
  #5  
Antiguo 12-11-2010
JXJ JXJ is offline
Miembro
 
Registrado: abr 2005
Posts: 2.408
JXJ Va por buen camino
tienes que revisar la version de tu base de datos.
que sea compatible con windows seven.
y si puedes actualiza el controlador de tu componente
me refiero a que si usad firebird 2.x y zeos. 5.

mejor actualiza tu componente para que soporte firebird

si quieres soporte unicode tienes que actualizar tambien delphi
no se si lazarus tenga soporte unicode.

a mi me ha pasado lo siguiente delphi 7 y windows seven
el programa compila bien . pero al mostrar los catalogos.
me dice error midas.

pero con delphi 2010 y windows seven no me da ese error.

algo parecido a lo tuyo.
Responder Con Cita
  #6  
Antiguo 13-11-2010
expertix expertix is offline
Registrado
 
Registrado: feb 2008
Ubicación: Nayarit, Mexico
Posts: 7
expertix Va por buen camino
buen dia nuevamente!

he leido su ayuda, estoy usando mysql server 5.0.21 y uso el conector de mysql ODBC 5.1.8, estoy usando consultas con parametros y creo que el problema surge al momento de insertar en la base de datos tal vez como ustedes dicen el problema esta en los parametros que le mando e investigado un poco y parece que windows 7 toma diferentes los formatos de la configuracion regional entonces revisare parte por parte los parametros que mando y tambien revisare el formato de la fecha, espero encontrar algo por ahi, seguire buscando y les informo, de antemano gracias.
Responder Con Cita
  #7  
Antiguo 14-11-2010
JXJ JXJ is offline
Miembro
 
Registrado: abr 2005
Posts: 2.408
JXJ Va por buen camino
usa tambien eurekalog
o alguno parecido

para que obtengas mas claro el error y la linea
Responder Con Cita
  #8  
Antiguo 26-11-2010
expertix expertix is offline
Registrado
 
Registrado: feb 2008
Ubicación: Nayarit, Mexico
Posts: 7
expertix Va por buen camino
solucionado

hola a todos!

pues resulta que ya he resuelto el problema y pues si efectivamente como ustedes decian el problema estaba en los parametros que mandaba al insertar en la tabla, era un error de programacion ya que se declaraba un parametro nunca recibia un valor y habia otro parametro que recibia un null cuando en la tabla el campo no permite null, como les digo es un error en la programacion y nunca me di cuenta porque de alguna manera con windows xp y con windows vista nunca me marcaron ese error y se pasaba por alto y se alamacenaba bien en la tabla cosa que con windows 7 no pasa con win7 si me marca ese error es por eso que yo creia que el codigo estaba correcto.

pero bueno gracias a sus aportes logre localizar el problema, gracias a todos.
Responder Con Cita
Respuesta


Herramientas
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
mydac y delphi 2007 en windows vista vroa74 OOP 0 18-09-2008 01:31:55
delphi 2007 ? plataforma windows o .NET ? BlueSteel Varios 11 18-07-2008 01:03:52
Distribuir una Aplicacion creada con Delphi 2007 y Firebird. Adrian Murua Firebird e Interbase 2 18-05-2008 17:13:01
Instalar aplicacion hecha on delphi 2007 y ADO juaahfer Varios 2 22-11-2007 03:14:47
Windows Vista y Delphi 2007 JF Sebastian Varios 3 22-05-2007 00:50:03


La franja horaria es GMT +2. Ahora son las 00:49:21.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi