Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Desarrollo en Delphi para iOS/OSX
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos


Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 28-12-2015
Avatar de EL WINDSURFISTA
EL WINDSURFISTA EL WINDSURFISTA is offline
Miembro
 
Registrado: Sep 2003
Posts: 19
Poder: 0
EL WINDSURFISTA Va por buen camino
Error consumiendo servicios web https desde Delphi 10 Seattle sobre IOS 9.1

Hola a todos:

Tengo una aplicación creada con delphi xe7 consumiendo servicios web https y funciona correctamente Windows, Android, OS X El Capitan y en IOS 8.3.
Al actualizar el iPad y iPhone a IOS 9.1, no funciona, he compilado la aplicación con Delphi 10 Seattle funciona bien en Windows, Android y OS X El Capitan, pero no en IOS 9.1, cuando ejecuto la aplicación en el iPad o iPhone me dice: Se ha producido un error de SSl y no se puede establecer una conexión segura con el servidor, creo que es un problema con las librerías: libcrypto.a y libssl.a

En Mac utilizo xCode 7.1.1

He añadido la unidad IdSSLOpenSSLHeaders_Static en los uses del proyecto:

Código Delphi [-]
uses
  {$IF Defined(IOS) and Defined(CPUARM)}
       IdSSLOpenSSLHeaders_Static,
  {$ELSE}
       IdSSLOpenSSLHeaders,
  {$ENDIF}
  FMX.Forms,
  ...

He copiado las librerías: libcrypto.a y libssl.a en el directorio del proyecto para que delphi lo incluya en el programa y también en ..\iOSDevice32\Debug

¿alguna solución?

Última edición por dec fecha: 28-12-2015 a las 15:22:37. Razón: Poner etiquetas DELPHI
Responder Con Cita
  #2  
Antiguo 29-12-2015
Avatar de EL WINDSURFISTA
EL WINDSURFISTA EL WINDSURFISTA is offline
Miembro
 
Registrado: Sep 2003
Posts: 19
Poder: 0
EL WINDSURFISTA Va por buen camino
Smile Error consumiendo servicios web https desde Delphi 10 Seattle sobre IOS 9.1

Hola a todos:

Ya lo tengo solucionado con Delphi XE7 !!!, solo seguir las indicaciones de Embarcadero:
https://community.embarcadero.com/bl...th-xe7-and-xe8

Lo he probado en IOS 9.0 y IOS 9.1 y va de maravilla. Por ahora me olvido de actualizar a Delphi 10 Seattle, utilizo la versión Enterprise y la actualización era un pastón.

Que tengáis un feliz 2016
Responder Con Cita
  #3  
Antiguo 29-12-2015
Avatar de Casimiro Notevi
Casimiro Notevi Casimiro Notevi is offline
Moderador
 
Registrado: Sep 2004
Ubicación: En algún lugar.
Posts: 28.482
Poder: 10
Casimiro Notevi Tiene un aura espectacularCasimiro Notevi Tiene un aura espectacular
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Ordenar DBGRID en Delphi 10 Seattle. jeremiselxi Trucos 3 26-11-2017 18:48:13
Error consumiendo servicios web desde Delphi XE7 sobre IOS 8.3 EL WINDSURFISTA Desarrollo en Delphi para iOS/OSX 3 07-05-2015 20:46:35
Consumiendo Webservices desde XE5 spobre IOS iMia Desarrollo en Delphi para iOS/OSX 3 18-06-2014 16:11:11
Llamada a Servicios Web desde Delphi 2006 (Delphi for Microsoft Win32) lacovera Internet 2 27-06-2007 16:54:29
PHP en Linux consumiendo componente Delphi en Windows utncs Providers 1 14-10-2004 00:43:35


La franja horaria es GMT +2. Ahora son las 12:58:16.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi