Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Delphi para la web
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 24-10-2017
Avatar de darkerbyte
darkerbyte darkerbyte is offline
Miembro
 
Registrado: Feb 2005
Posts: 183
Poder: 14
darkerbyte Va por buen camino
Unhappy Error al conectarse a un webservice

Mis estimados colegas:

Estoy tratando de conectarme a un webservice. El proveedor me ha proporcionado la siguiente liga:

https://www.fel.mx/CR33/ConexionRemota.svc?WSDL

Así que traté de utilizar el WSDL de Delphi (XE5) y me saca el siguiente error:

Cita:
An error encoutered importing

'https://www.fel.mx/CR33/ConexionRemota.svc?WSDL' :

Unable to load WSDL File/Location:

https://www.fel.mx/CR33/ConexionRemota.svc?WSDL

Error [No se encontró el encabezado solicitado - URL:...://www.fel.mx/CR33/ConexionRemota.svc?WSDL - SOAPAction:""]"

Please verify that you've entered thecorrect URL/File and that it's a valid WSDL file.

Do you want to try again?
Echenme una manita, ¿que me esta faltando para poder conectarme?

Gracias de antemano
Responder Con Cita
  #2  
Antiguo 24-10-2017
bitbow bitbow is offline
Miembro
 
Registrado: Jul 2006
Posts: 365
Poder: 12
bitbow Va camino a la fama
Hola, no se si este sea tu problema pero la ruta que tiene el WSDL contiene la definicion por lo que si estas consumiendo con esa url el webservice te va a marcar error, la url del webservice debe ser sin el wsdl.

Referente al error (No se encontró el encabezado), valida si entre los requisitos o en el WSDL tienes definicion de cabeceras SOAP.

<XML>
<wsp:ExactlyOne><wsp:All><sp:TransportBinding><wsp:Policy><sp:TransportToken><wsp:Policy><sp:HttpsTo ken RequireClientCertificate="false"/></wsp:Policy></sp:TransportToken><sp:AlgorithmSuite><wsp:Policy><sp:Basic256/></wsp:Policy></sp:AlgorithmSuite><sp:Layout><wsp:Policy><sp:Strict/></wsp:Policy></sp:Layout></wsp:Policy></sp:TransportBinding></wsp:All></wsp:ExactlyOne>
</XML>

Saludos.
__________________
¡Ni como ayudarte Niño!!
bitbow
Responder Con Cita
  #3  
Antiguo 25-10-2017
[egostar] egostar is offline
Registrado
 
Registrado: Feb 2006
Posts: 6.422
Poder: 19
egostar Va por buen camino
Hola

Pues no se tiene problema alguno para consumirlo.

Lo hice con XE2 sin problema, tal vez es la forma como lo estás importando, si nos muestras como lo estás haciendo es mas fácil ayudarte.

Adjunto la imagen de lo que hice.

Saludos
Imágenes Adjuntas
Tipo de Archivo: png wsdl FEL.png (81,2 KB, 16 visitas)
__________________
"La forma de empezar es dejar de hablar y empezar a hacerlo." - Walt Disney
Responder Con Cita
  #4  
Antiguo 25-10-2017
Avatar de darkerbyte
darkerbyte darkerbyte is offline
Miembro
 
Registrado: Feb 2005
Posts: 183
Poder: 14
darkerbyte Va por buen camino
Thumbs up Importando

Gracias amigo [egostar] por contestar,


1. Cree un proyecto nuevo "VCL Forms applicacion"
2. Me fui a Menu component -> Import WSDL
3. Ya en el asistente, en "Location of WSDL file or URL" puse la liga que me dió el proveedor:
https://www.fel.mx/CR33/ConexionRemota.svc?WSDL
4. Autehtication la dejé los tres campos en blanco
5. En SOAP version la dejé en automático
6. Le di en finalizar y es cuando me sacaba el mensaje de error.

Cuando digo "me sacaba" quiero decir que acabo de intentarlo y esta vez si me dejó.
Así que ahora estoy mas confundido porque hace un rato estuve intentando varias veces, con diferentes parámetros y siempre me generaba el mismo mensaje de error.
Estoy pensando quizá fue alguna situación con el servidor

Agradezco de verdad a cada uno su valioso tiempo por leer mi post y por sus respuestas.
Responder Con Cita
  #5  
Antiguo 25-10-2017
Avatar de ElKurgan
[ElKurgan] ElKurgan is offline
Miembro Premium
 
Registrado: Nov 2005
Posts: 1.062
Poder: 14
ElKurgan Va por buen camino
Confirmo que con Delphi XE7 tampoco da ningún problema de acceso

Y si, a veces pasa que el servidor deja de comunicar (o el propio equipo local, por culpa del firewall)

saludos
Responder Con Cita
  #6  
Antiguo 25-10-2017
[egostar] egostar is offline
Registrado
 
Registrado: Feb 2006
Posts: 6.422
Poder: 19
egostar Va por buen camino
Cita:
Empezado por darkerbyte Ver Mensaje

....Cuando digo "me sacaba" quiero decir que acabo de intentarlo y esta vez si me dejó.
Así que ahora estoy mas confundido porque hace un rato estuve intentando varias veces, con diferentes parámetros y siempre me generaba el mismo mensaje de error.
Estoy pensando quizá fue alguna situación con el servidor.....
Tal vez tenias algún problema de conectividad de internet.

Lo bueno es que ya pudiste acceder al servicio.

Saludos
__________________
"La forma de empezar es dejar de hablar y empezar a hacerlo." - Walt Disney
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Error SoapHttp webservice Delphi 7 adripugliesso Varios 2 11-12-2015 13:33:02
Error en Webservice funcion envio de sms webmasterplc Delphi para la web 5 25-07-2013 20:10:29
Error en WebService y Windows 7 adebonis Internet 3 30-12-2011 20:42:16
error al conectarse desde otra maquina jhcaboverde Conexión con bases de datos 4 23-09-2007 01:22:58
Error al conectarse varios a una base Paradox Walterdf Conexión con bases de datos 1 02-12-2003 22:08:20


La franja horaria es GMT +2. Ahora son las 06:58:39.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi