Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Otros entornos y lenguajes > C++ Builder
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 10-09-2017
pollo_c pollo_c is offline
Miembro
 
Registrado: oct 2006
Posts: 55
Poder: 12
pollo_c Va por buen camino
Dbgrid solo muestra campos tipo INT, campos varchar no los muestra

Estimados solicito su apreciable ayuda ya que este error no lo he podido solucionar al ejecutar Query el DBGrid solo muestra los campos tipo Int y tipo DATE, los campos tipo CHAR Y VARCHAR no los muestra, el código sql es simple
Código SQL [-]
 SELECT * FROM instalaciones
, dicha tabla tiene los siguientes campos:

ID_INST INT AUTOINC
NOM_INST VARCHAR(50)
PUEBLO_INST VARCHAR(50)
ID_REG INT
DIR_INT VARCHAR(200)
EDO_INST INT
ID_TEC INT
FECHASOL DATE
FECHAINST DATE

Al ejecutar el codigo sql anterior el DBGrid solo muestra 6 campos INT Y DATE, ya probé al mismo Query que ejecute el codigo
Código SQL [-]
 SELECT * FROM reportes
sin problemas muestra todos los campos de la tabla INT, VARCHAR Y DATE, otra prueba fue eliminar la tabla instalaciones y creé una tabla nueva llamada prueba la cual solo di de alta dos campos uno es tipo INT y el otro es VARCHAR, al aplicar el Query con el siguiente codigo
Código SQL [-]
 SELECT * FROM prueba
solo se muestra el DBGrid el campo tipo INT.

Saludos.

Responder Con Cita
  #2  
Antiguo 10-09-2017
Avatar de ecfisa
ecfisa ecfisa is offline
Moderador
 
Registrado: dic 2005
Ubicación: Tres Arroyos, Argentina
Posts: 9.824
Poder: 27
ecfisa is a splendid one to beholdecfisa is a splendid one to beholdecfisa is a splendid one to beholdecfisa is a splendid one to beholdecfisa is a splendid one to beholdecfisa is a splendid one to behold
Hola.

Es extraño, ¿ Que RDBMS, que versión de C++ Builder y que componentes de conexión estas usando ?

Saludos
__________________
Daniel Didriksen

Guía de estilo - Uso de las etiquetas - La otra guía de estilo ....
Responder Con Cita
  #3  
Antiguo 10-09-2017
pollo_c pollo_c is offline
Miembro
 
Registrado: oct 2006
Posts: 55
Poder: 12
pollo_c Va por buen camino
Ya solucione el error

hola ecfisa:
Uso MySql y Builder 6, el detalle son las tablas que ya había creado y que funcionaban a la perfección, dichas tablas tenían como tipo de cotejamiento latin1_swedish_ci al momento de crear nuevas tablas se crearon con el cotejamiento tipo utf8_spanish_ci, este ultimo los Query solo regresaban los campos tipo INT Y DATE.

Ya quedo solucionado pero nos podrían explicar por que el builder6 se comporto extraño?
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Intraweb TIWDBGrid no muestra los DisplayLabels de los campos fcios Internet 2 22-12-2009 05:45:17
IBQuery1 solo muestra 1 registro ascrnet Conexión con bases de datos 2 24-12-2007 05:00:52
muestra 2 hojas y solo imprime 1 m8estrella83 Impresión 0 01-11-2006 21:11:22
Maestro detalle solo muestra un registro jandres Varios 2 10-06-2006 13:11:49
VK DBF no me muestra los campos enteros zurech Conexión con bases de datos 1 08-06-2006 17:09:33


La franja horaria es GMT +2. Ahora son las 17:55:08.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi