Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Providers
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 22-06-2007
amkalzada amkalzada is offline
Miembro
 
Registrado: May 2006
Posts: 11
Poder: 0
amkalzada Va por buen camino
Aplicación Servidora como servicio

Tengo una aplicación en 3 capas con conexión por Socket y modulos de datos remotos en un exe. Decidí instalarla como servicio de windows con el parámetros "c:\mi_aplicación.exe" -install y a partir de ese momento aunque la tenga ejecutada de forma manual ejecuta la instancia del servicio del usuario System, ignorando la que tengo ejecutando. Si intento remover el servicio ("c:\mi_aplicación.exe" -remove) la ejecuta de nuevo, de manera que sigue quedando como servicio del usuario system. ¿Cómo puedo quitar el servicio?

Un Saludo y gracias de antemano
Responder Con Cita
  #2  
Antiguo 23-06-2007
Avatar de droguerman
droguerman droguerman is offline
Miembro
 
Registrado: Apr 2005
Ubicación: tierra
Posts: 999
Poder: 13
droguerman Va por buen camino
anda al registro hkey_LOCAL_MACHINE\System\CurrentControlSet\Services y borra la entrada de tu servicio
__________________
self.free;
Responder Con Cita
  #3  
Antiguo 23-06-2007
amkalzada amkalzada is offline
Miembro
 
Registrado: May 2006
Posts: 11
Poder: 0
amkalzada Va por buen camino
No ha funcionado así

Lo primero darte las gracias por tu respuesta.

Bueno pues eso lo estuve probando, así como eliminar todas las referencias en el registro de windows de los módulos de datos remotos... y ni reiniciando ni nada ha funcionado..

Me he pasado bueno rato buscando todas las referencias posibles en el registro a la aplicación y nada.. y mira que he borrado más de 200 claves de registro.. pero nada de nada...

Muchas gracias tio.


Un saludo
Responder Con Cita
  #4  
Antiguo 28-06-2007
amkalzada amkalzada is offline
Miembro
 
Registrado: May 2006
Posts: 11
Poder: 0
amkalzada Va por buen camino
Problema solucionado

Pues eso que ya lo he solucionado. La cuestión era que el scktsrvr se lanzaba como servicio y por tanto como usuario system y los procesos que eran llamados por este se ejecutaban también como usuario system, y por tanto la aplicación servidora corría como usuario system.

Un saludo y gracias.
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Aplicacion como servicio fjav182 Varios 1 16-02-2007 19:17:37
Mi Firebird intenta arrancar como servicio y también como aplicación Héctor Randolph Firebird e Interbase 1 30-11-2006 10:47:13
Aplicación como Servicio Rysiu Varios 4 15-01-2006 19:45:50
Aplicación como servicio Oskar API de Windows 3 13-09-2004 13:35:34
Mi aplicacion como un servicio de Windows Julio César Varios 1 27-07-2004 19:37:31


La franja horaria es GMT +2. Ahora son las 14:24:49.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi