Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > Varios
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo Hace 2 Días
iMia iMia is offline
Miembro
 
Registrado: Jul 2010
Posts: 55
Poder: 8
iMia Va por buen camino
Unhappy Win10 1803 y BDE... No se pueden abrir fichero y aparece el error "No more files"

Buenas a todos...
Como sabéis se estan actualizanco los windows 10 a la April release 1803..
Pues bien... este cambio me está provocando serios problemas... No se pueden abrir fichero y aparece el error "No more files".
Segun la poca información que he encontrado (DBE + "No more files") puede ser debido a un cambio de Windows en la comprobacion de los permisos y comparticiones. Esto podría provocar que los sistemas por encima del SO, crean que no pueden abrir más archivos, mientras el SO se toma su tiempo en comprobar permisos, y en este caso el BDE salta un "No More Files" como podría haber saltado un "File Not Found"...
¿A alguien más le ha pasado?
Responder Con Cita
  #2  
Antiguo Hace 2 Días
iMia iMia is offline
Miembro
 
Registrado: Jul 2010
Posts: 55
Poder: 8
iMia Va por buen camino
Unhappy

Cita:
Empezado por iMia Ver Mensaje
Buenas a todos...
Como sabéis se estan actualizanco los windows 10 a la April release 1803..
Pues bien... este cambio me está provocando serios problemas... No se pueden abrir fichero y aparece el error "No more files".
Segun la poca información que he encontrado (DBE + "No more files") puede ser debido a un cambio de Windows en la comprobacion de los permisos y comparticiones. Esto podría provocar que los sistemas por encima del SO, crean que no pueden abrir más archivos, mientras el SO se toma su tiempo en comprobar permisos, y en este caso el BDE salta un "No More Files" como podría haber saltado un "File Not Found"...
¿A alguien más le ha pasado?
Además, buceando por la red (más que navegando...) sobre las características que se desactivan en la Spring Creators, hay la desaparación del Grupo de Hogar (Home Group), la desactivación de SMB 1.0 (por temas de seguridad?), uso de la compatibilidad nativa para IPV6, por lo que parece quie ha tocado el tema de compartición y usos de red...

Yo noté un problema con delphi. Tengo el VirtualBox sobre Fedora 27 con una VM con Win10. Ahí tengo instalado Delphi Tokyo. Tengo la un servidor de ficheros mapeado a una unidad... pues bien, antes de la actualización, 0 problemas... todo perfectio...pero desde la actualización, desde delphi al hacer un abrir, donde me deberian aparecer las unidades mapeadas (Equipo), no me aparecen. Solo puedo abrir por //servidor/recursoCompartido....

¿nadie se ha actualizado a Win10 1803?
Responder Con Cita
  #3  
Antiguo Hace 1 Día
iMia iMia is offline
Miembro
 
Registrado: Jul 2010
Posts: 55
Poder: 8
iMia Va por buen camino
Talking Arreglado!!!

Cita:
Empezado por iMia Ver Mensaje
Además, buceando por la red (más que navegando...) sobre las características que se desactivan en la Spring Creators, hay la desaparación del Grupo de Hogar (Home Group), la desactivación de SMB 1.0 (por temas de seguridad?), uso de la compatibilidad nativa para IPV6, por lo que parece quie ha tocado el tema de compartición y usos de red...

Yo noté un problema con delphi. Tengo el VirtualBox sobre Fedora 27 con una VM con Win10. Ahí tengo instalado Delphi Tokyo. Tengo la un servidor de ficheros mapeado a una unidad... pues bien, antes de la actualización, 0 problemas... todo perfectio...pero desde la actualización, desde delphi al hacer un abrir, donde me deberian aparecer las unidades mapeadas (Equipo), no me aparecen. Solo puedo abrir por //servidor/recursoCompartido....

¿nadie se ha actualizado a Win10 1803?
Bueno...
¡¡¡Parece que ya lo he solucionado!!!!

El problema está en la desactivación de SMB v.1... cuando juntas en una red un W10 prof. con la 1803 y otras con Win10 1709 o anterior, al quedar desactivado el SMB v1, tienen problemas para comunicarse... pasan al netbios y parece que la red funciona OK desde el propio SO...
Simplemente hay que activar la compatibilidad con SMB 1. Esto está en Panel de control, Alpicaciones, Activar o desactivar caracteristicas de Windows (o directamente ejecutado "appwiz-cpl start")

De los 3500 clientes, ya tenia 7 incidencias en 2 dias... me veia la semana siguiente con 500 ... y final de semana colgado de un pino...
Responder Con Cita
  #4  
Antiguo Hace 1 Día
iMia iMia is offline
Miembro
 
Registrado: Jul 2010
Posts: 55
Poder: 8
iMia Va por buen camino
Unhappy no sé, no sé...

Cita:
Empezado por iMia Ver Mensaje
Bueno...
¡¡¡Parece que ya lo he solucionado!!!!

El problema está en la desactivación de SMB v.1... cuando juntas en una red un W10 prof. con la 1803 y otras con Win10 1709 o anterior, al quedar desactivado el SMB v1, tienen problemas para comunicarse... pasan al netbios y parece que la red funciona OK desde el propio SO...
Simplemente hay que activar la compatibilidad con SMB 1. Esto está en Panel de control, Alpicaciones, Activar o desactivar caracteristicas de Windows (o directamente ejecutado "appwiz-cpl start")

De los 3500 clientes, ya tenia 7 incidencias en 2 dias... me veia la semana siguiente con 500 ... y final de semana colgado de un pino...
Bueno... sigo informando...
Siguen pasando cosas raras... salta de forma aleatoria...
Tambien está pasando cno Win10 y ODBC contra ORACLE y MS-SQLServer ... https://social.msdn.microsoft.com/Fo...elopmentissues
Probando otras cosas... Windows defender, avgs, Esets, Avast, y lo ultimo probarçé lo que dicen en el enlace de arriba... en el servidor, poner el ejecutable en una carpeta no compartida... y en la carpeta compartida, sólo los datos...
Responder Con Cita
  #5  
Antiguo Hace 1 Día
Avatar de Ñuño Martínez
Ñuño Martínez Ñuño Martínez is offline
Moderador
 
Registrado: Jul 2006
Ubicación: Ciudad Catedral, Españistán
Posts: 5.699
Poder: 18
Ñuño Martínez Va camino a la famaÑuño Martínez Va camino a la fama
Gracias por mantenernos informados. Que te sea leve y lo logres solucionar.
__________________
Proyectos actuales --> Allegro 4 Pascal|MinGRo Game Engine
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Por que me aparece siempre este error !! ??? llSnakell Varios 10 25-01-2011 06:06:08
Error al abrir fichero blaiselaborde Conexión con bases de datos 1 14-07-2010 16:17:20
Abrir un fichero .fdb Delphitest Conexión con bases de datos 2 17-09-2006 17:46:57
crear y abrir fichero beatriz g Varios 1 21-08-2006 12:50:34
Urge: Error TOO MANY OPEN FILES mrmanuel Conexión con bases de datos 4 01-12-2005 11:05:31


La franja horaria es GMT +2. Ahora son las 14:20:36.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi