Club Delphi  
    FTP   CCD     Buscar   Trucos   Trabajo   Foros

Retroceder   Foros Club Delphi > Principal > API de Windows
Registrarse FAQ Miembros Calendario Guía de estilo Buscar Temas de Hoy Marcar Foros Como Leídos

Respuesta
 
Herramientas Buscar en Tema Desplegado
  #1  
Antiguo 28-02-2018
Avatar de Maniches
Maniches Maniches is offline
Miembro
 
Registrado: Nov 2012
Ubicación: Lima - Perú
Posts: 50
Poder: 6
Maniches Va por buen camino
Lightbulb Componente API OPOS - No se visualiza?

Hola Amigos del Foro.
Actualmente estoy usando los componentes Epson OPOS y he importado su ActiveX (*.ocx) si bien es cierto me ha generado el componente bien y sus librería (..._CCO_TLB.pas).
Este componente no es visual en el formulario, pero al momento de colocarlo en el formulario no me muestra su imagen. me crea toda su definición en código (*.pas).
HE visualizado el código del (*.dfm) el componente es: OPOSPOSPrinter1

Código Delphi [-]
  OnCreate = FormCreate
  PixelsPerInch = 96
  TextHeight = 13
  object OPOSPOSPrinter1: TOPOSPOSPrinter
    Left = 192
    Top = 23
    Width = 0
    Height = 0
    ControlData = {00090000D8130000D8130000}
  end
  object btnPrintOPOS: TButton
    Left = 36
    Top = 30

Quisiera por favor me ayudan dando una pista de como se soluciona el poder ver el componente en el formulario.

Ojo: Toda la definición vía código se crea de forma normal y me compila todo, el detalle que no se visualiza el componente en el diseño. he adjuntado la imagen de lo que esta pasando.

opos_comp.png

Muchas gracias por sus comentarios o sugerencias.

Saludos.
__________________
Maniches
maniches@outlook.com
Responder Con Cita
  #2  
Antiguo 28-02-2018
Avatar de Neftali [Germán.Estévez]
Neftali [Germán.Estévez] Neftali [Germán.Estévez] is offline
[becario]
 
Registrado: Jul 2004
Ubicación: Barcelona - España
Posts: 15.671
Poder: 10
Neftali [Germán.Estévez] Tiene un aura espectacularNeftali [Germán.Estévez] Tiene un aura espectacular
Ya se que es una tontería, pero has probado a cambiar esto:

Código Delphi [-]
Width = 0     
Height = 0

POr esto otro (aunque sea manualmente para probar):

Código Delphi [-]
Width = 40
Height = 40
__________________
Germán Estévez => Web/Blog
Guía de estilo, Guía alternativa
Utiliza TAG's en tus mensajes.
Contactar con el Clubdelphi

P.D: Más tiempo dedicado a la pregunta=Mejores respuestas.
Responder Con Cita
  #3  
Antiguo 01-03-2018
Avatar de Maniches
Maniches Maniches is offline
Miembro
 
Registrado: Nov 2012
Ubicación: Lima - Perú
Posts: 50
Poder: 6
Maniches Va por buen camino
Lightbulb

Hola Germán,

He intentado de las 2 formas:
1. Poniendo los valores que indicas desde el INSPECTOR y el valor se resetea a 0. no me permite asignar ningún valor.
2. he asignado por texto al archivo *.dfm y luego cuando veo el formulario y intento ver el texto del formulario (View as Text) se resetea y vuelve a los valores en 0.
incluso he eliminado la definición: ControlData = {00090000D8130000D8130000}, se vuelve a crear dicha definición.

parece que en el componente esas propiedades en alguna parte se han configurado con valores en 0 tanto para: Width y Height


Me da una sospecha que tenga que ver con el archivo *.DCR. cuando lo importe desde el *.OCX no estaba considerado este archivo en el paquete que se crea. en la paleta de componentes no me mostraba el icono del componente. agregue esa linea de código (adj. código) y al instalar el paquete sin me agrego la imagen original del componente (en la paleta de componentes).
Sera que no esta encontrando dicho archivo *.dcr al momento de usar el componente? en que parte de las carpetas de Delphi tienen que ir estos archivos *.dcr?

gracias por sus comentarios.


Código Delphi [-]
package OPOSPrinter;

{$R *.res}
{$R 'OposPOSPrinter_CCO_TLB.dcr'}
{$IFDEF IMPLICITBUILDING This IFDEF should not be used by users}
{$ALIGN 8}
{$ASSERTIONS ON}
__________________
Maniches
maniches@outlook.com
Responder Con Cita
  #4  
Antiguo 01-03-2018
Avatar de Neftali [Germán.Estévez]
Neftali [Germán.Estévez] Neftali [Germán.Estévez] is offline
[becario]
 
Registrado: Jul 2004
Ubicación: Barcelona - España
Posts: 15.671
Poder: 10
Neftali [Germán.Estévez] Tiene un aura espectacularNeftali [Germán.Estévez] Tiene un aura espectacular
Cita:
Empezado por Maniches Ver Mensaje
...agregue esa linea de código (adj. código) y al instalar el paquete sin me agrego la imagen original del componente (en la paleta de componentes).
Sera que no esta encontrando dicho archivo *.dcr al momento de usar el componente? en que parte de las carpetas de Delphi tienen que ir estos archivos *.dcr?
Tal vez falló algo en la importación y no te añadió esa línea.
Lo raro es que no saliera la imagen por defecto que tiene delphi.

Esos ficheros si existen, normalmente están junto a los fuentes del componente que se instala o se importa (si es que los lleva).
__________________
Germán Estévez => Web/Blog
Guía de estilo, Guía alternativa
Utiliza TAG's en tus mensajes.
Contactar con el Clubdelphi

P.D: Más tiempo dedicado a la pregunta=Mejores respuestas.
Responder Con Cita
  #5  
Antiguo 01-03-2018
Avatar de Maniches
Maniches Maniches is offline
Miembro
 
Registrado: Nov 2012
Ubicación: Lima - Perú
Posts: 50
Poder: 6
Maniches Va por buen camino
Lightbulb

Germán.
Me ha pasado que en algunas importaciones lo ha agregado y a veces no lo ha agregado la imagen original del componente en la paleta de componentes.
por ello modifique el paquete para que al instalarlo nuevamente ya me muestre la imagen original. (como vez en la imagen se ve todo bien en la paleta de componentes).

Lo raro que esta pasando es que no se muestra la imagen del componente en el formulario. por mas que toda la definición vía código si se agrega de forma normal.

Tengo claro que los archivos *.dcr son generados y se ubican en la carpeta del componente importado, pero no se si mis sospecha de lo que ocurre tenga que ver con ese archivo. Ya que ese archivo contiene la imagen del componente. capaz al momento de registrarse en delphi no este quedando bien cuando este se usa.

Voy a seguir investigando y si encuentro algo les comunico.

Saludos.
__________________
Maniches
maniches@outlook.com
Responder Con Cita
Respuesta


Herramientas Buscar en Tema
Buscar en Tema:

Búsqueda Avanzada
Desplegado

Normas de Publicación
no Puedes crear nuevos temas
no Puedes responder a temas
no Puedes adjuntar archivos
no Puedes editar tus mensajes

El código vB está habilitado
Las caritas están habilitado
Código [IMG] está habilitado
Código HTML está deshabilitado
Saltar a Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
No se visualiza el TChart mblascog Gráficos 1 25-05-2014 18:17:18
Usar OPOS con impresora fiscal IBM PD15 neaptide Impresión 0 21-10-2010 16:05:39
Imprimir usando OPOS seoane Impresión 7 06-10-2008 23:05:55
No visualiza el form ecfisa OOP 2 19-03-2008 11:25:07
Drivers OPOS???? tarco35 Impresión 2 19-01-2007 20:58:24


La franja horaria es GMT +2. Ahora son las 21:02:05.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traducción al castellano por el equipo de moderadores del Club Delphi
Copyright 1996-2007 Club Delphi