Ver Mensaje Individual
  #3  
Antiguo 06-03-2018
tsk tsk is offline
Miembro
 
Registrado: Dec 2017
Posts: 16
Reputación: 0
tsk Va por buen camino
En si pip install fdb no te instala libfbclient2 ese lo tienes que instalar vía

apt-get install libfbclient2

Por lo que se me hace raro que digas que te instala la versión 3.0.

Con fdb puedes acceder a los 2.1, 2.5,3.0 dependiendo de la librería libfbclient2.so que esté instalada en tu sistema.

La última versión de armbian viene con la versión 2.5.4 de libfbclient2

En la raspberry pi puedes ver de que versión dispones ejecutando el siguiente comando

apt-cache show libfbclient2

Si algunas consultas devuelven errores ha de ser por otra razón, y las pistas te las van a dar el tipo de consultas que te regresen el error.

No conozco firebird, pero por lo poco que acabo de leer maneja 3 dialectos sql, ¿Podría ser ese el problema?. Por defecto la función connect pone el parámetro sql_dialect=3, prueba cambiando ese parámetro a 1.
Responder Con Cita